With a little side of applesauce...

Thursday, May 6, 2010

Ubuntu Lucid / Macbook - Rhythmbox segmentation fault

If you are getting the following errors:
found device path /dev/sda2 for mount /media/Macintosh HD
device /dev/sda2 has no ID_MEDIA_PLAYER tag in udev
/media/Macintosh HD is already a mount point
override file /media/Macintosh HD/.is_audio_player not found on mount /media/Macintosh HD
(10:15:18) [0x9f83028] [rb_removable_media_manager_add_mount] rb-removable-media-manager.c:785: Unhandled media
(10:15:18) [0x9f83028] [uevent_cb] rb-removable-media-manager.c:591: add event for /sys/devices/pci0000:00/0000:00:04.0/usb3 (10bd00)
(10:15:18) [0x9f83028] [create_source_device_cb] rb-mtp-plugin.c:405: trying to match device 10bd00 (usb device 1) against detected mtp devices
(10:15:18) [0x9f83028] [create_source_device_cb] rb-mtp-plugin.c:436: device didn't match anything
(10:15:18) [0x9f83028] [uevent_cb] rb-removable-media-manager.c:591: add event for /sys/devices/pci0000:00/0000:00:04.0/usb3/3-0:1.0 (0)
(10:15:18) [0x9f83028] [create_source_device_cb] rb-mtp-plugin.c:391: can't get udev device number for device 3-0:1.0
(10:15:18) [0x9f83028] [uevent_cb] rb-removable-media-manager.c:591: add event for /sys/devices/pci0000:00/0000:00:04.0/usb3/3-1 (10bd06)
(10:15:18) [0x9f83028] [create_source_device_cb] rb-mtp-plugin.c:405: trying to match device 10bd06 (usb device 7) against detected mtp devices
Segmentation fault



Uninstall rhythmbox-plugins:

sudo apt-get remove rhythmbox-plugins

7 comments:

walterl said...

I had the same problem and, prompted by your advice, removed rhythmbox-ubuntuone-music-store, and it worked fine. Thanks for the inspiration. :)

Shannon Eric Peevey said...

That's great! In my case removing rhythmbox-ubuntuone-music-store didn't fix the issue, so I had to be more heavy-handed, which is a bit frustrating... for now :)

Seven said...

I also had to be heavy handed and remove all pluggins. Has there been a bug submitted yet?

Shannon Eric Peevey said...

Go figure! To test and see if the problem was a missing libgnomevfs2-extra package, I reinstalled the rhythmbox-plugins and rhythmbox-ubuntuone-music-store, and rhythmbox doesn't crash this time...

2010-05-06 10:12:16 status installed rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-06 10:12:17 remove rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1 0.0.9-0ubuntu1
2010-05-06 10:12:17 status half-configured rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-06 10:12:17 status half-installed rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-06 10:12:17 status config-files rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-06 10:12:17 status config-files rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-06 10:21:43 status installed rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 remove rhythmbox-plugins 0.12.8-0ubuntu4 0.12.8-0ubuntu4
2010-05-06 10:21:44 status half-configured rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 status half-installed rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 status config-files rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 status config-files rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 status config-files rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-06 10:21:44 status not-installed rhythmbox-plugins
2010-05-10 09:00:53 install rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:00:53 status half-installed rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:00:59 status unpacked rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:00:59 status unpacked rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:01:00 configure rhythmbox-plugins 0.12.8-0ubuntu4 0.12.8-0ubuntu4
2010-05-10 09:01:00 status unpacked rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:01:00 status half-configured rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:01:00 status installed rhythmbox-plugins 0.12.8-0ubuntu4
2010-05-10 09:02:51 install rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1 0.0.9-0ubuntu1
2010-05-10 09:02:51 status half-installed rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:52 status unpacked rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:52 status unpacked rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:53 configure rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1 0.0.9-0ubuntu1
2010-05-10 09:02:53 status unpacked rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:53 status half-configured rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:53 status installed rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:54 status triggers-awaited rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1
2010-05-10 09:02:54 status installed rhythmbox-ubuntuone-music-store 0.0.9-0ubuntu1

Shannon Eric Peevey said...

BTW, that is from my /var/log/dpkg.log

Alex Tomic said...

Stumbled on here after getting a similar problem. You might want to take a look at this, it seems to be macbook pro hardware-related (luckily there's an easy workaround)

https://bugs.launchpad.net/ubuntu/+source/rhythmbox/+bug/553655

Shannon Eric Peevey said...

Thanks, Alex! Your comment makes everything clear, as MTP is a Microsoft protocol for browsing portable devices. If you check out libgnomevfs2-extra, it adds smb support for Gnome VFS, for browsing Windows shares. I have updated the bug with this information.