With a little side of applesauce...

Tuesday, April 28, 2009

Eclipse - Cannot find a solution satisfying the following requirements org.eclipse.swt [3.4.0.v3448f].

If you are the recipient of the above error, here is the cause:
"This is most likely an error from P2 (Eclipse's update mechanism in Eclipse 3.4 and higher). The problem seems to be that the Mylyn update site is not enabled in your copy of Eclipse. There is a bug in Eclipse that these sites may not be automatically enabled even though we specify that we require them for installation.

If any of the installed features have unsatisfied dependencies or if features were previously installed from the extras or incubator update site, P2 may fail with an error similar to the one above."

Here is the fix.

With the related bug:
https://studio.atlassian.com/browse/PLE-393

3 comments:

Bruno Medeiros said...

I think the solution on the link is gone. I'm trying to solve that but don't know how.
Can you help?

Shannon Eric Peevey said...

Hi Bruno,

Try this new link:
http://confluence.atlassian.com/display/IDEPLUGIN/Installation+Error+-+Cannot+Find+a+Solution+Satisfying+the+Following+Requirements

Shannon Eric Peevey said...

Try again:
http://confluence.atlassian.com/display/IDEPLUGIN/Installation+Error+-+Cannot+Find+a+Solution+Satisfying+the+Following+Requirements