With a little side of applesauce...

Thursday, February 19, 2009

Eclipse Ganymede - problems installing JBoss Tools

When trying to install the JBoss Tools into Eclipse, I kept getting the following error:

Cannot complete the request. See the details.
Unsatisfied dependency: [org.jboss.tools.birt.feature.feature.group 1.0.0.CR2-R200901280154] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.birt.integration.wtp.ui/[2.3.1.v20080827,2.3.1.v20080827]
Unsatisfied dependency: [org.jboss.tools.birt.feature.feature.group 1.0.0.CR2-R200901280154] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.birt.integration.wtp.feature.group/[2.3.1,3.0.0)

The fix for this is to use the correct BIRT repository:

c) Help > Software Updates > Available Software > Add Site > http://download.eclipse.org/birt/update-site/2.3/
c) Help > Software Updates > Available Software > Add Site > http://download.jboss.org/jbosstools/updates/nightly/trunk/

Thanks to Nick Boldt for the fix!
http://lists.jboss.org/pipermail/jbosstools-issues/2008-November/022794.html

No comments: